[DISPONIBILITE] Windows 10 2004 et/ou 20H2

Venez ici partager vos infos et nouvelles informatiques !
Répondre
Avatar du membre
ThiWeb
Administrateur
Administrateur
Messages : 9266
Enregistré le : il y a 11 ans
Localisation : On earth
Contact :

Message par ThiWeb »

Et comment je fais ça ?...
Le MCT check la machine et me propose d'installer la 2004...
J'ai pas d'option pour ne fait qu'un diagnostique... 🙄

ThiWeb
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 7953
Enregistré le : il y a 11 ans

Message par LaDidi21 »

@ThiWeb :
Ça veut, donc, dire que M$ bloque volontairement la mise à jour (cf. plus haut) et que tu ne peux pas savoir pourquoi :@
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Avatar du membre
ThiWeb
Administrateur
Administrateur
Messages : 9266
Enregistré le : il y a 11 ans
Localisation : On earth
Contact :

Message par ThiWeb »

Bah oui... Je savais bien tout ça...
Le tool me dit que dal et m'upgrade en 2004/20H2 si je ne l'interromps pas...
La question est de savoir ce qui bloque WU...

ThiWeb
Bill_Boquet
Habitué
Habitué
Messages : 152
Enregistré le : il y a 6 ans

Message par Bill_Boquet »

ThiWeb a écrit : il y a 3 mois Sachant qu'il a été mis en avant le fait que la non-disponibilité de la 2004/20H2 pour certains PC était liée à la carte son Conexant, j'ai revérifié mes pilotes.
Lors de mon acharnement, j'avais trouvé un pilote Conexant datant du 16/03/2020, version 8.66.95.69.

Mais même avec cette version très à jour de la carte son, Windows Update m'affichait toujours l'encart comme quoi "La 2004 sera prochainement disponible, bla bla bla...".
Donc même avec un pilote de 2020 pour ma carte son, pas de disponibilité pour la 2004 / 20H2...
Sauf si quelqu'un a un pilote plus récent que la version 8.66.95.69 du 16/03/2020.

Pour info, l'ID de la carte est le suivant : HDAUDIO FUNC_01 VEN_14F1 DEV_510F (Conexant SmartAudio HD).

Ayant refait une install clean de la 1909 en BIOS (et pas en UEFI, pour le test), je n'ai pour l'instant pas l'encart de WU, concernant la 2004 / 20H2.
Et la version du pilote de la carte son, installée par Microsoft, date du 18/08/2015 cette fois, version 8.66.16.55.
Pour l'instant, je ne touche à rien, en attendant que l'encart de WU réapparaisse.

ThiWeb
@ThiWeb, désolé, je ne peux pas faire avancer ton schmilblik. Dans la liste "known issues" du lien :
https://docs.microsoft.com/en-us/window ... ws-10-20h2
je suis dans la catégorie Conexant du dernier lien et pas de l'avant-dernier, soit le "Conexant ISST audio driver".
Mon pilote mis à jour grâce au "HP Assistant" est daté du 19/06/2020, version 9.0.239.10.
Comme toi, malgré le fait que cette version soit bien postérieure aux versions qui posent problème, je suis toujours bloqué en 1909.
MS indique :"To safeguard your update experience, we have applied a compatibility hold on Windows 10 devices with affected Conexant or Synaptics audio drivers installed from being offered Windows 10, version 2004 or Windows Server, version 2004 until the driver has been updated. If your organization is using Update Compliance, the safeguard IDs are ...".
Pour ma part, j'ai toujours l'encart de WU m'annonçant l'Arlésienne, aka la version 2004.
Bien que mon pilote soit à jour, bernique ! Bref, j'arrête de me casser la tête et j'attends la 1H21 :smiley:
@+, Bill
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 7953
Enregistré le : il y a 11 ans

Message par LaDidi21 »

@ThiWeb :
Tu as donc la confirmation que RIEN n'interdit la migration ^^

Regarde si tu ne trouves pas une information utile dans les logs ? cf. https://support.microsoft.com/en-us/hel ... -of-window
Tu as testé SetupDiag.exe du 16/08/2019 (cf. SetupDiag) ?
Sinon, il ne te reste que Get-WindowsUpdateLog...

Tu n'as pas la possibilité d'ouvrir un case chez M$ ?
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Avatar du membre
ThiWeb
Administrateur
Administrateur
Messages : 9266
Enregistré le : il y a 11 ans
Localisation : On earth
Contact :

Message par ThiWeb »

Je sais bien que RIEN n'interdit à mon PC de passer en 2004/20H2.
J'ai fais une install clean de la 20H2, aucun problème.

Maintenant, je suis volontairement repassé en 1909 et j'aimerais savoir POURQUOI WU m'affiche que la 2004 n'est pas encore certifiée pour ma machine.

C'est purement psychologique.
Car en effet, je sais très bien qu'elle fonctionne parfaitement.

ThiWeb
Avatar du membre
Silvertip
Habitué
Habitué
Messages : 166
Enregistré le : il y a 2 ans

Message par Silvertip »

@ThiWeb

Y a un petit logiciel qui traine sur la toile (Windows 10 Update Assistant) pour vérifier les problèmes de compatibilité .

Alors je sais que tu va me répondre que WU est fait pour ça mais peut être que ce log va répondre à tes questions du pourquoi Windows 2004 n'est pas compatible avec ta machine (ou pas) !!!

Code : Tout sélectionner

Microsoft Windows 10 Update Assistant is designed to prepare your computer for upgrading or updating Windows 10 by checking for compatibility issues and ing all necessary files to start the install.

While Microsoft Windows 10 Update Assistant can check your computer to see if it can run Windows 10.

Beyond that, Windows 10 Update Assistant is geared towards advanced users and IT departments looking to get the latest large updates, for example, the Fall Creators Update.

In other words, Microsoft Windows 10 Update Assistant can updates that are available but not in your Windows Updates yet. Everyone will eventually get the larger updates through Windows Updates.
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 7953
Enregistré le : il y a 11 ans

Message par LaDidi21 »

@Silvertip :
:pensive: Lis un peu avant de proposer : https://support.microsoft.com/en-ie/hel ... -assistant
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Avatar du membre
Silvertip
Habitué
Habitué
Messages : 166
Enregistré le : il y a 2 ans

Message par Silvertip »

@LaDidi21

Ha oui en effet, décidément faut que je me reprenne en main moi ^^
Avatar du membre
oujassav
Habitué
Habitué
Messages : 213
Enregistré le : il y a 11 mois

Message par oujassav »

@thiweb je ne sais pas si j'ai bien suivi ton problème, mais peut être que le pilote d'un des composants de ton pc est en contradiction avec les principes de Microsoft et donc tant que ton constructeur ne sortira pas une maj pour redresser le tire, WU refusera de te donner sa bénédiction :)
Avatar du membre
ThiWeb
Administrateur
Administrateur
Messages : 9266
Enregistré le : il y a 11 ans
Localisation : On earth
Contact :

Message par ThiWeb »

Je suis bien d'accord avec toi oujassav, mais la vraie question est... quel est le périphérique concerné ?
Je serais le premier à aller frapper à la porte du constructeur du composant concerné histoire de télécharger la mise à jour en premier...

Mais pour l'instant, c'est l'inconnue totale... CG ? Wi-Fi ? Son ? Etc.
Vers qui dois-je me tourner ? Tout en sachant que j'ai déjà mis à jour 99 % des pilotes de mon PC (Conexant, Intel, ASUS, Synaptic, etc.), sans changement dans WU...

ThiWeb
Avatar du membre
Kapitan
Nouveau
Nouveau
Messages : 109
Enregistré le : il y a 6 mois

Message par Kapitan »

Il serait alors intéressant de donner la liste détaillée de tes composants et de procéder par élimination :
Tous ceux qui ont le même composant que toi et qui ont pu avoir la mise à jour te le feront savoir, jusqu'à identifier le composant dont le pilote est en cause (si le problème vient bien de là).
Avatar du membre
Kapitan
Nouveau
Nouveau
Messages : 109
Enregistré le : il y a 6 mois

Message par Kapitan »

... ou/et de le faire avec le parc de PC que tu entretiens...
Bill_Boquet
Habitué
Habitué
Messages : 152
Enregistré le : il y a 6 ans

Message par Bill_Boquet »

Comme expliqué précédemment, je suspectais le "Conexant ISST audio driver" d'être la cause du blocage de mon PC professionnel en version 1909.
https://docs.microsoft.com/en-us/window ... 417msgdesc
J'avais fait récemment une mise à jour de ce pilote avec le logiciel "HP Assistant". Ce dernier m'avait installé un nouveau pilote, mais je restais bloqué en version 1909.
J'ai relu attentivement l'explication du site MS : "The affected driver will be named Conexant ISST Audio or Conexant HDAudio Driver under Sound, video and game controllers in Device Manager and have file name uci64a96.dll through uci64a231.dll and a file version lower than 7.231.3.0."
J'ai constaté que j'avais en effet un fichier uci64a231.dll avec une version 7.231.3.0. Flûte, juste à la limite d'une version posant problème.
J'ai cherché sur le net si d'autres avaient trouvé une solution. Certains proposaient un pilote du site HP, mais je n'étais pas sûr qu'il convienne à ma machine.
Par acquit de conscience, je suis allé voir si HP proposait un pilote récent spécifique à ma machine et c'était le cas depuis le 11 septembre 2020.
Hier téléchargement, installation, redémarrage de ma machine ... et toujours bloqué en version 1909.
Cependant, lueur d'espoir : le fichier uci64a231.dll était maintenant en version 7.231.4.0.
Ce matin, Windows Update m'indiquait toujours le blocage en 1909.
J'ai redémarré ma machine et bingo : Windows Update m'a enfin proposé la mise à jour 20H2 ;-).
La mise à jour a mis près de 2 heures, mais après plus de 6 mois d'attente, je suis enfin en 20H2.
En résumé pour ceux qui sont bloqués en 1909 et qui ont un pilote audio Conexant : vérifiez éventuellement sur le site du constructeur de votre machine si une mise à jour est disponible.
Avatar du membre
ThiWeb
Administrateur
Administrateur
Messages : 9266
Enregistré le : il y a 11 ans
Localisation : On earth
Contact :

Message par ThiWeb »

Très intéressant Bill_Boquet !
Je vais ceuser le problème Connexant !

Pour ma part, j'ai fait un énième test sur ma machine.
Je suis repassé en UEFI (vu que le problème ne vient pas de là), et j'ai installé la 2004 pour voir si Windows Update me proposait la 20H2.
Et... Oui ! Juste après avoir installé la 2004 et mis à jour les pilotes de la machine, la 20H2 est immédiatement apparue dans WU.

Donc, même face à un hypothétique problème de compatibilité de pilote avec un 2004, si on force l'installation de cette dernière, les mises à jour majeures suivantes de Windows 10 continuent d'être proposée.
Ou alors, c'est que la 20H2 ne fait pas autant de vérifications matérielles que la 2004...

Quoiqu'il en soit, c'est déjà rassurant de savoir que les mises à jour suivantes continuent d'être proposée.

Sachant que Bill_Boquet semble avoir trouvé la cause du blocage de la 1909 vers la 2004/20H2, liée au pilote Conexant, je vais peut-être retenter un install en 1909.
Pour info, ma carte son est une Conexant High Definition SmartAudio et le pilote que j'avais testé date du 12/03/2020.

Concernant le fichier UCI64A231.dll, ma version est presque la même que la tienne, à savoir la 7.231.2.0.
Je vais chercher une mise à jour du pilote pour voir la version 7.231.4.0 pour le fichier UCI64A231.dll du pilote de la carte son Conexant.

En tous cas, BRAVO à toi d'avoir trouvé la cause ! Je ne comprends pas que Microsoft n'ait pas poussé la mise à jour de ce pilote, si c'est effectivement le responsable du blocage du passage des 1909 vers les 2004/20H2.

Je retourne à mes tests et à la 1909 et je te tiens au courant.
Encore merci ! ;)

ThiWeb
Bill_Boquet
Habitué
Habitué
Messages : 152
Enregistré le : il y a 6 ans

Message par Bill_Boquet »

@Thiweb, you're welcome :).
J'ai regardé sur le site ASUS de ton portable, mais pas de mise à jour disponible du driver d'origine qui date en effet de 2015.
Je n'ai pas non plus trouvé sur le net de témoignage d'utilisateurs ASUS qui avaient résolu le problème.
Bonne m..., mais si tu n'as pas la chance d'avoir comme moi une mise à jour du constructeur, c'est "challenging" :cold_sweat:.
@+, Bill
Avatar du membre
ThiWeb
Administrateur
Administrateur
Messages : 9266
Enregistré le : il y a 11 ans
Localisation : On earth
Contact :

Message par ThiWeb »

Tu appelles "constructeur", ce qui n'est en réalité qu'un assembleur.
ASUS et HP ne fabriquent pas la carte son Conexant.
C'est... CONEXANT justement.

Donc... J'ai téléchargé le pilote Conexant contenant le fichier UCI64A231.dll en version 7.231.4.0 sur le site d'HP :
https://ftp.hp.com/pub/softpaq/sp110001 ... 110234.exe 706 Mo sa race !!! Pour un pauvre pilote de carte son !!!
Ce sont vraiment des gros cons chez HP.

Quoiqu'il en soit, après extraction du pilote depuis l'exécutable HP, je sors un dossier de 160 Mo qui compressé, tombe à 129 Mo.
C'est déjà plus acceptable, même si ça reste lourd pour un pauvre pilote.

J'ai étudié ensuite l'INF du pilote en question et un paradoxe apparait clairement.
MON pilote correspond à la version 8.66.95.69 datant du 16/03/2020 (UCI64A231.dll version 7.231.2.0).
Le pilote fournit par HP, correspond à la version 8.65.319.160 datant du 07/09/2020 (UCI64A231.dll version 7.231.4.0).
Ça n'a aucun sens !

La version la plus ancienne du pilote (fournit par HP), possède une DLL plus récente que celle du pilote le plus récent !
C'est complètement absurde !!

Quoiqu'il en soit, pilote de mars ou de septembre 2020, je m'en branle un peu.
Si c'est la version 7.231.2.0 de la DLL UCI64A231.dll qui empêche l'obtention de la 2004/20H2, je vais installer la version plus ancienne du pilote pour avoir la bonne DLL et espérer ainsi, passer en 2004/20H2 via WU !

Je viens de réinstaller une 1909 UEFI clean.
Je MAJ tout via WU, j'attends l'encart 2004 et je me concentre sur la carte son.

Merci encore à toi en tous cas d'avoir je pense, trouvé LA solution pour débloquer ce super bordel ! ;)

ThiWeb
Avatar du membre
Auteur du sujet
Warum
Ultra VIP
Ultra VIP
Messages : 1627
Enregistré le : il y a 7 ans
Localisation : Dans le fond de l'Ardeche

Message par Warum »

@ThiWeb
j'attend avec impatience le résultat de des tes , le 2 portable Lenovo que j'ai ont tout les deux des carte Conexant mais sur le site Lenovo pas de mise a jour rien-nada je suis en 2016
je vais contrôlé le modèle peut être j'ai de la chance
merci pour la suite de l'épopée
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 7953
Enregistré le : il y a 11 ans

Message par LaDidi21 »

@ThiWeb :
Ça a l'air d'être un beau bordel chez Conexant...
cf. catalog M$ :
  • 27/06/2019 | "8.66.96.52" | X40PlmwaU.inf | "HDAUDIO\FUNC_01&VEN_14F1&DEV_510F" | CHDRT64.sys | 8.66.96.0 | sha1 + sha256 de M$ HCP
  • 11/03/2020 | "8.66.95.69" | X40Plmwa.inf | "HDAUDIO\FUNC_01&VEN_14F1&DEV_510F" | CHDRT64.sys | 8.66.95.0 | sha1 + sha256 de M$ HCP | Pourquoi 2 drivers, mystère
On retrouve, bien, dans les 2 drivers Conexant & AMD :

Code : Tout sélectionner

...
.data:000000014011EE80 aHdaudioFunc01V:                        ; DATA XREF: AddDevice+A2↓o
.data:000000014011EE80                 text "UTF-16LE", 'HDAUDIO\FUNC_01&VEN_14F1',0
.data:000000014011EEB2                 align 8
.data:000000014011EEB8 aHdaudioFunc01V_1:                      ; DATA XREF: AddDevice+EB↓o
.data:000000014011EEB8                 text "UTF-16LE", 'HDAUDIO\FUNC_01&VEN_1002',0
.data:000000014011EEEA                 align 10h
.data:000000014011EEF0 aHdaudioFunc01V_0:                      ; DATA XREF: AddDevice+BA↓o
.data:000000014011EEF0                 text "UTF-16LE", 'HDAUDIO\FUNC_01&VEN_11D4',0
.data:000000014011EF22                 align 8
.data:000000014011EF28 aIntelaudioFunc:                        ; DATA XREF: AddDevice+D6↓o
.data:000000014011EF28                 text "UTF-16LE", 'INTELAUDIO\FUNC_01&VEN_14F1',0
...
Tu es sûr de
ThiWeb a écrit : il y a 3 mois...
Pour info, l'ID de la carte est le suivant : HDAUDIO FUNC_01 VEN_14F1 DEV_510F (Conexant SmartAudio HD).
car les .inf des 2 drivers suivants ne la gère pas (aucun 510F)...

Le pilote d'HP (lien ThiWeb) a été mis en ligne le 17/11/2020.
Il date du 07/09/2020 et est en version 8.65.319.160.
Le fameuse DLL ne sert que comme CoInstaller.
Le vrai driver c'est "CHDRT64.sys" en version 8.65.319.160. Il est signé sha1 (du 02/10/2018 au 02/10/2020) et sha256 (du 02/10/2018 au 02/10/2020).
Il est contre-signé avec un certificat Symantec (du 23/12/2017 au 23/03/2029).

Le Conexant HD Audio driver" version 11.27.4561.148 Rev.Q (fourni par Bill_Bocquet ci-après) a été mis en ligne le 29/10/2020.
Il date du 10/09/2020 et est en version 8.65.320.30.
Le driver CHDRT64.sys est en version 8.65.320.30. Il est signé sha1 (du 30/08/2018 au 30/08/2020), sha256 (du 02/10/2018 au 02/10/2020)... et sha256 (du 30/08/2018 au 30/08/2020) :kiss:
Il est contre-signé avec un certificat Symantec (du 23/12/2017 au 23/03/2029).
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Bill_Boquet
Habitué
Habitué
Messages : 152
Enregistré le : il y a 6 ans

Message par Bill_Boquet »

Merci @ ThiWeb et @LaDidi21 pour les données complémentaires. Pour info, les pilotes de mon portable HP EliteBook 850 G4 sont à l'adresse suivante :
https://support.hp.com/be-fr/drivers/se ... c/11122333
Et le "Conexant HD Audio driver" version 11.27.4561.148 Rev.Q peut être téléchargé à :
https://ftp.hp.com/pub/softpaq/sp109001 ... 109030.exe

Pour mon portable, c'est donc le fichier sp109030.exe, pour le même modèle G5 c'est un autre, etc. Après extraction :
Le fichier ver.txt indique une version 8.65.320.30 / 9.0.239.30
La version du fichier UCI64A231.dll du 10/09/2020 est 7.231.4.0
La version du fichier CHDRT64.sys du 10/09/2020 est 8.65.320.30

Cette version a l'air plus récente que celle que vous avez téléchargée. Problème de date : 07/09 ou 09/07/2020 ?
Sorry, je n'ai pas pu vérifier, le téléchargement du pilote HP prend plus de 2 heures chez moi.
Dans tous les cas, l'important c'est que ça fonctionne 8|.
@+, Bill.
Bill_Boquet
Habitué
Habitué
Messages : 152
Enregistré le : il y a 6 ans

Message par Bill_Boquet »

Warum a écrit : il y a 3 mois @ThiWeb
j'attend avec impatience le résultat de des tes , le 2 portable Lenovo que j'ai ont tout les deux des carte Conexant mais sur le site Lenovo pas de mise a jour rien-nada je suis en 2016
je vais contrôlé le modèle peut être j'ai de la chance
merci pour la suite de l'épopée
@Warum : je ne connais pas le modèle de tes portables, mais Lenovo a apparemment mis à jour récemment certains pilotes, par exemple :
https://pcsupport.lenovo.com/il/en/prod ... s/ds105864
Bonne chasse, Bill :smiley:
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 7953
Enregistré le : il y a 11 ans

Message par LaDidi21 »

@Bill_Boquet :
De mémoire, c'est un ASUS ^^
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Avatar du membre
ThiWeb
Administrateur
Administrateur
Messages : 9266
Enregistré le : il y a 11 ans
Localisation : On earth
Contact :

Message par ThiWeb »

Mais les gars, on s'en fout de Lenovo ou d'ASUS ou d'HP, on vous dit que le constructeur c'est Conexant.
Arrêtez de regarder chez les assembleurs, sauf si ces derniers proposent des pilotes Conexant justement, qui seraient plus à jour chez l'un que chez l'autre.

Pour ma part, je suis retourné sur une 1909 propre et à jour.
J'attends pour l'instant, que l'encart de la 2004 apparaisse dans WU, ce qui n'est pas encore le cas vu que ma machine est fraichement réinstallée.
Normalement 24/48H.

Je vous tiens au courant quand ce sera le cas, et si le pilote avec la DLL à jour corrige le problème.
Si le pilote ne passe pas, je changerais juste la DLL d'un pilote l'autre pour voir.

ThiWeb
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 7953
Enregistré le : il y a 11 ans

Message par LaDidi21 »

@ThiWeb :
Tu pourrais répondre à ce que j'ai écrit sur l'ID de ta carte ?
Je ne suis même pas sûr que ce soit Conexant le constructeur...
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Avatar du membre
Auteur du sujet
Warum
Ultra VIP
Ultra VIP
Messages : 1627
Enregistré le : il y a 7 ans
Localisation : Dans le fond de l'Ardeche

Message par Warum »

Bill_Boquet a écrit : il y a 3 mois
Warum a écrit : il y a 3 mois @ThiWeb
j'attend avec impatience le résultat de des tes , le 2 portable Lenovo que j'ai ont tout les deux des carte Conexant mais sur le site Lenovo pas de mise a jour rien-nada je suis en 2016
je vais contrôlé le modèle peut être j'ai de la chance
merci pour la suite de l'épopée
@Warum : je ne connais pas le modèle de tes portables, mais Lenovo a apparemment mis à jour récemment certains pilotes, par exemple :
https://pcsupport.lenovo.com/il/en/prod ... s/ds105864
Bonne chasse, Bill :smiley:
pour répondre a ta question Bill Boquet je ne trouve aucune mise a jour

un de mes portable est
LENOVO 80Q7
BIOS Version D5CN47WW
Date 26/08/2016
CARTES MÈRES
Fabricant LENOVO
Modèle Paris 5A8
Version SDK0J40709 WIN
Intel Core I7 -6500U-CPU@2.50GHz
DD Samsung SSD 850 EVO 2 to
Mémoire 16 GB

et pour Conexant
Fournisseur (Provider)
Conexant
Nom (Name)
CHDRT64.sys
Version
8.66.29.53
Date
26/07/2016
Détails du périphérique
ID de périphérique (Device Id)
HDAUDIO\FUNC_01&VEN_14F1&DEV_510F&SUBSYS_17AA3822&REV_1001\4&D1D0A9A&0&0001

merci si quelqu'un a une solution
l'encadrement célèbre est toujours affiché
Bill_Boquet
Habitué
Habitué
Messages : 152
Enregistré le : il y a 6 ans

Message par Bill_Boquet »

@Warum : Après lecture de pas mal de posts sur le forum Lenovo, le problème de mise à jour vers Windows 10 1909 ou 20H2 semble être généralisé pour les portables Lenovo.
Jusqu'à présent, beaucoup d'utilisateurs parlent du problème, de leurs tentatives de résolution mais il n'y a pas de solution plébiscitée. En résumé :

1) Dans le Readme du lien précédemment envoyé, Lenovo semble indiquer que cette version du pilote résout le problème :
https://pcsupport.lenovo.com/il/en/prod ... s/ds105864
<8.66.89.0> (N1GA510W)
- (Fix) Fixed an issue where Conexant Audio driver blocked Windows Update.

2) Cependant, MS continue à bloquer ce pilote :
https://docs.microsoft.com/en-us/window ... 377msgdesc
"The affected driver will be named Conexant HDAudio Driver under Sound, video and game controllers in Device Manager and have versions 8.65.47.53, 8.65.56.51, or 8.66.0.0 through 8.66.89.00 for chdrt64.sys or chdrt32.sys."

3) Même sur des machines Lenovo récentes, certains semblent rencontrer des problèmes avec Windows 10 2004 ou 20H2.
https://forums.lenovo.com/t5/Windows-10 ... -p/5050584
Ici, on conseille même de downgrader en 1909 :dizzy:.

4) Dans ce post, @bananaman explique avoir réussi en forçant la mise à jour avec Windows Update Assistant :
https://forums.lenovo.com/t5/ThinkPad-X ... -p/5041091
Perso, je ne tenterai cela qu'avec une installation préalable du pilote du 1). En effet, les pilotes plus anciens (dont le tien) risquent de provoquer les problèmes expliqués par MS.

5) Dans cet autre post, @tamachans explique une démarche intéressante :
https://forums.lenovo.com/t5/Lenovo-P-Y ... -p/5043919
Il a désinstallé le pilote Audio Conexant et l'a remplacé avec le pilote générique Microsoft. Il a ensuite réussi à effectuer la migration vers 2004, non sans heurt.
Je suppose que l'étape suivante serait de réinstaller une version récente du pilote Audio Conexant, mais pas expliqué.
Edit : voici un lien qui explique la procédure :
https://linustechtips.com/topic/1252855 ... 20-update/

En conclusion, il semble que les problèmes potentiels liés à ce pilote audio Conexant sur les machines Lenovo restent suffisamment sérieux pour que MS continue de bloquer la mise à jour vers 2004 ou 20H2.
Je n'ai pas suivi l'historique, mais les versions 8.66.89.xx du pilote que Lenovo indique résoudre le problème restent quand même bloquées par MS pour les raisons expliquées sur leur site.
1 ou 2 personnes indiquent avoir réussi à contourner l'interdiction de mise à jour, mais il n'y a pas de confirmation massive de ces succès.
Ta machine n'est pas toute neuve et je n'ai aucune idée si les pilotes récents conviendraient à ta configuration.
Bref, si j'étais dans ta situation, j'attendrais et regarderais de temps en temps si des solutions sont confirmées par plusieurs utilisateurs.
@+, Bill.

P.S. : @LaDidi21, à propos du beau b... chez Conexant, la raison des pilotes HP version 8.65.xxx mis à jour est peut-être simplement le retour à une version antérieure du pilote car la version 8.66.yyy pose problème ? Oui je sais, pourquoi pas 8.67.zzz alors :smiley:.
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 7953
Enregistré le : il y a 11 ans

Message par LaDidi21 »

@Bill_Boquet :
Sauf que si tu fais un retour arrière, tu reviens à une date antérieure... et non postérieure !
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Bill_Boquet
Habitué
Habitué
Messages : 152
Enregistré le : il y a 6 ans

Message par Bill_Boquet »

@LaDidi21 : Sauf si tu tu repars d'une version antérieure et que tu fais une mise à jour de cette version. Mais à vrai dire, je n'ai pas vérifié le détail des dates.
Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités