[PROBLEME] Comment utiliser correctement un SSD M.2 ?

Pour de l'aide concernant votre matériel
Répondre
Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9228
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

[PROBLEME] Comment utiliser correctement un SSD M.2 ?

Message par ThiWeb » il y a 10 mois

Bonjour à tous,
Image

Je viens de finir de mettre en place mon M.2 960 Pro sur ma ROG Maximus VIII, et ça fait super mal ^^
Maintenant, étant novice dans les SSD, je cherche à savoir si j'ai pas oublié quelques points.

Tout d'abord, l'indexation est désactivée et la défragmentation/optimisation aussi.
Les pilotes Samsung sont installés pour le contrôleur, et tout me semble aller parfaitement.

Mais je sais qu'il y a une histoire de TRIM à activer, à lancer ou à désactiver, je sais plus...
Egalement, mon SSD étant un M.2, HD Tunes ne le voit pas... Comment donc puis-je faire une surveillance du SMART, si ça existe toujours dans ce type de périphérique.
A défaut, comment puis-je surveiller son bon fonctionnement tout au long de sa vie ?
L'UEFI m'affiche bien l'état SMART des périphériques SATA, mais là non plus, pas du M.2... :$

Enfin, je sollicite des conseils sur la bonne utilisation d'un tel produit.
Actuellement, Windows est installé dessus et les dossiers dans %userprofile% sont délocalisés dans un disque mécanique.
Donc, je profite de la vitesse du SSD pour Windows et pour les programmes qui sont installés sur ma machine.
Pour le stockage, ça reste sur un disque dur traditionnel (un petit 2 To Blue flambant neuf).

Avez-vous d'autres conseils ou suggestions à m'apporter ?

Merci d'avance à tous ;)

ThiWeb

Avatar du membre
Joselito
Habitué
Habitué
Messages : 443
Enregistré le : il y a 5 ans

Message par Joselito » il y a 10 mois

Bonjour Thiweb,
Pourquoi se limiter à un disque mécanique pour les données ? Un problème de coût ?
La panne du SSD qui survient sans prévenir ?
Mais si tu archives tes données régulièrement sur un NAS ou un autre support, tu t'en fiches.
Non ?

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9228
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 10 mois

Utiliser un SSD pour stocker des données dormantes, ce serait vraiment inutile...
Donc un disque dur traditionnel me semble clairement plus à propos.

Pour le système et l'exécution des programmes par contre, là oui !
Je veux bien investir dans un SSD de 1 ou 2 To pour mon stockage et pour te faire plaisir, mais les gains de performance seront juste identiques à un disque traditionnel.

ThiWeb

Avatar du membre
GUW
Modérateur
Modérateur
Messages : 284
Enregistré le : il y a 9 ans

Message par GUW » il y a 10 mois

Salut Thiweb
pour avoir les performances optimales il faut que le port M2 de ta carte soit compatible NVMe, sinon il fonctionnera mais en s'interfaçant avec le driver AHCI. Dans ce cas il vaut mieux prendre une interface SATA classique qui sera un peu moine chère.
A vérifier sur la documentation de la carte mère(Mais si tu l'as déjà acheté c'est un peu tard. J'ai pas vérifié t'as CM.


-Vérifier l'activation de la commande TRIM - Windows 10
Cliquez avec le bouton droit de la souris sur le bouton Démarrer.
Cliquez sur Invite de commandes (admin).
Saisissez alors la commande suivante et validez par la touche Entrée.
fsutil behavior query DisableDeleteNotify

Si la commande retourne DisableDeleteNotify = 0, la commande TRIM est bien activée.
Si elle retourne DisableDeleteNotify = 1, la commande n'est pas activée. Dans ce cas, saisissez la commande suivante pour l'activer :
fsutil behavior set DisableDeleteNotify 0

Bonne soirée.

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9228
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 10 mois

Merci pour ta réponse GUW.

Résultat de la commande :

Code : Tout sélectionner

NTFS DisableDeleteNotify = 0
ReFS DisableDeleteNotify n’est pas positionné
Donc à priori, tout est bon.

Pour la compatibilité NVMe, je vais aprofondir la question.
Mais je viens de voir une vidéo YouTube précisant la sélection d'une option M.2 dans l'UEFI...
Il s'agit d'une Maximus VII et non VIII...

Je vais regarder cette option.
Serais-ce cette option qui rend le port M.2 compatible NVMe ?

Merci encore,

Edit :
Selon Clubic, ASUS certifie la ROG Maximus Ranger VII comm étant certifiée NVMe :
http://www.clubic.com/carte-mere/actual ... -nvme.html
Donc si la VII est certifiée, en toute logique, la VIII aussi non ?

Mais je serais curieux de savoir où ça se règle dans l'UEFI, car je n'ai rien vu concernant le terme NVMe... $)

ThiWeb

Avatar du membre
GUW
Modérateur
Modérateur
Messages : 284
Enregistré le : il y a 9 ans

Message par GUW » il y a 10 mois

Oui ta carte est certifiée
T'as pas besoin de modifier les paramètres dans le BIOS pour x4 et Gen 3.
Tout est défini automatiquement lorsque le lecteur Nvme est installé.
ET sur windows 10 tu as les pilotes en natif

Tu peux vérifier le réglage de ton lecteur M2 dans le BIOS sous le contrôleur PCH
reste sur auto si tu as des doutes.
Le logiciel Samsung Magician .Lui je pense qu'il te donneras des indications.
Va pas trop vite pour les mises à jours.SI cela marche bien.Touche pas pour l'instant.

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9228
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 10 mois

Merci encore GUW pour toutes ces infos !

Content de voir que je n'ai rien à faire de spécial dans l'UEFI.
Après avoir installé le SSD M.2, l'install de Windows me l'a reconnu direct et s'est installé dessus.
Par contre, il a reconnu mon disque dur branché sur le SATA 0 en lecteur n°1 et le M.2 en lecteur n°2.
J'ai installé Windows sur le SSD (n°2 donc).
Est-ce normal selon toi, que le port M.2 soit reconnu en second lecteur et pas en premier par rapport au SATA ?

Pour les réglages à vérifier, je vais quand même regarder ça, mais sans faire mon geekounet du dimanche...
Ça fonctionne nickel pour l'instant, donc pourquoi toucher ;) c'est juste pour comprendre et savoir par acquis de conscience où sont les réglages.

Quand tu dis, "va pas trop vite pour les mises à jours", que veux-tu dire ?
- Mon UEFI utilise la derniere version publiée par ASUS (3703 - Fixed SAMSUNG M.2 device issue) ce qui, vu les indications d'ASUS tombe bien :)
- Mon Windows 10 Pro 1709 x64 est 100 % à jour, y compris la MAJ qui foire sur 1 PC sur 2.

Bref, je suis à jour de tous les côté.

Ah, et concernant les pilotes natifs de Windows concernant le M.2, j'ai installé le pilote du contrôleur NVMe de Samsung par dessus ceux de Windows 10.
C'est ce qui semble conseillé partout pour une bonne prise en charge du SSD...
Je ne pense pas qu'il soit préférable de conserver le pilote par défaut de Windows, si ? :$

Merci encore pour ton aide ;)

ThiWeb

Avatar du membre
GUW
Modérateur
Modérateur
Messages : 284
Enregistré le : il y a 9 ans

Message par GUW » il y a 10 mois

@ThiWeb
En ce qui concerne les numérotations de tes disques.
A tu fais une clean install ou une migration sur ton SSD ? Si c'est une migration qu'il soit en 1 c'est normal.
Ton SSD était seul branché ou le deuxième disque aussi lors de l’installation ? Dans ce cas.
Ce problème se produit car les lecteurs sont énumérés dans l’ordre dans lequel ils sont présentés au système d’exploitation par le biais de Plug-and-Play.
Cohérence apparente de numérotage de disques est fortuite ou un effet secondaire du matériel et des pilotes utilisés.
Dans le cas d'un SSD M2 NVMe,je sais pas dans quel ordre sont présentés les disques.Question intéressante à approfondir.

Pour les mises à jour , je parle des drivers Samsung c'est avec eux qu'il y a un problème de démarrage lors d'une mise à jour de WINDOWS 10
et aucun problème avec les natifs (à vérifier) Il est bon d'attendre quelques retours avant de mettre à jour ces drivers.

Et dernière chose quand on veut installer du matos comme ton SSD M2 .C'est là que l'on voit la différence d'une ROG avec une autre CM entrée de gamme . :idea: ^^

Bonne soirée.

Avatar du membre
Ghostfly
Administrateur
Administrateur
Messages : 1482
Enregistré le : il y a 9 ans
Localisation : Localhost

Message par Ghostfly » il y a 10 mois

Pour contrôler l'état de santé tu peux utiliser SSDLife qui est fait pour ça
Posté avec mon Macbook Pro sous macOS Mojave #ThiRevolution

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9228
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 10 mois

@Ghost : Merci pour le logiciel, je vais regarder ça quand je l'aurais trouvé en version crackée.

@GUW : Tu te doutes bien que sur du matos pareil, une migration m'aurais fait mal au cœur ^^
C'est évidement une clean install.
Sauf que lors de ma clean install, le M.2 et le disque dur SATA 0 était branché...
Le SATA 0 est devenu le lecteur 0 et le M2, le lecteur 1.

Pas très grave tout ça, mais ça manque un peu de logique.
Ceci dit, les PC ASUS VivoBook S15 qui sont vendus avec un M.2 + HDD, se présente de la même façons dans l'install de Windows 10...
Y'a peut-être une cohérence de la marque, mais de mon point de vue, dommage qu'un M.2 ne soit pas reconnu comme le lecteur 0 par rapport aux SATA.

Pour le driver Samsung, je l'ai installé après avec installé Windows 10 évidemment.
Ce qui m'a emmerdé d'ailleurs, c'est qu'on ne peux pas se passer de l'EXE à la con alors qu'un INF aurait été tellement plus clean.
Une fois installé, on peut le récupérer, désinstaller et installer via l'INF, mais... que de manips à la con pour rien...

Je suppose que lors de la prochaine grosse MAJ de Windows 10, le problème des M.2 de Samsung sera résolu.
Toujours est-il qu'ASUS a sorti une MAJ spécifique pour corriger les M.2 Samsung...
Le problème sur ma carte est donc peut-être déjà résolu.
Dans le cas contraire, je saurais d'où vient le problème, et je repasserais sur le pilote natif de Microsoft si nécessaire.

Que veux-tu dire par on voit la différence avec une RoG quand on veut installer M.2 ?
Je suppose que c'est une compliment ? ^^

Merci encore pour ton aide ;)

ThiWeb

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités