[RÉSOLU] Port M.2 SATA incompatible NVMe ?

Pour de l'aide concernant votre matériel
Répondre
Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9422
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

[RÉSOLU] Port M.2 SATA incompatible NVMe ?

Message par ThiWeb » il y a 3 semaines

Bonjour,

J'ai un PC fixe ASUS RoG Strix GL12CP. Lors de l'achat, j'ai constaté que la carte mère de ce PC possédait un port M.2
J'ai donc naturellement acheté en même temps (32 Go de RAM et…) un Samsung 970 EVO NVMe :
https://www.amazon.fr/dp/B07CGGP7SV

Une fois l'ordi reçu, la nouvelle RAM fonctionne nickel, le SSD M.2 d'origine (SK Hynix SC308 (HFS128G39TND)) aussi, bref tout va bien.
Je décide donc de changer le SSD M.2 par mon Samsung 970 EVO NVMe comme prévu.

Et là… c'est le drame ! Le SSD n'est pas reconnu… Et je trouve kedal sur le net…
Sauf qu'après quelques réflexions et observations personnelles, je me rend compte que le SSD M.2 d'origine semble être un M.2 SATA et pas NVMe !
Le problème viendrait-il de là ?! Un port M.2 SATA n'accepterait-il donc pas un SSD NVMe ? Ça semble logique, même si ça reste très con…

Je me tourne donc vers vous pour une confirmation de ma théorie…
Inutile de me demander d'aller dans le BIOS/UEFI et/ou de le mettre à jour. Il n'y a aucune référence à la technologie NVMe dans le BIOS/UEFI… et… le BIOS est à jours évidemment (v309).

Merci d'avance !

P.S. : J'ai acquis d'office un Samsung 860 EVO SATA qui, si ma théorie est exacte, devrait fonctionner, contrairement au 970 EVO…

ThiWeb

Avatar du membre
Joselito
Grand Habitué
Grand Habitué
Messages : 575
Enregistré le : il y a 5 ans

Message par Joselito » il y a 3 semaines

@ThiWeb
Un article pas mal sur Harware.fr qui tente de faire le point.
https://forum.hardware.fr/hfr/Hardware/ ... 4769_1.htm

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 4453
Enregistré le : il y a 9 ans

Message par LaDidi21 » il y a 3 semaines

@ThiWeb :
Le SK Hynix SC308 est un SATA.
+1 / Joselito : Le M.2 n'est QU'UN facteur de forme (1 dimension, la largeur) !
Par contre, selon https://www.asus.com/fr/Tower-PCs/ROG-S ... fications/, tu as un emplacement M.2 de type NVMe.
Tu n'as pas la référence exacte de la CM ?
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9422
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 3 semaines

@Ladidi : Oui j'ai vu.
Mais le modèle que j'ai, diffère...

Le port M.2 que j'ai semble clairement limité à fonctionner en SATA et pas en NVMe malheureusement.

Le SSD rentre bien, mais non reconnu.

Donc si le port est un SATA, normal que le NVMe ne soit pas reconnu si je comprends bien...

ThiWeb

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 4453
Enregistré le : il y a 9 ans

Message par LaDidi21 » il y a 3 semaines

@ThiWeb :
Les deux s'excluent mutuellement. Cela dépend du contrôleur où le port M.2 est attaché
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9422
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 3 semaines

Bon et bien je reçois le 860 EVO SATA demain.
Il devrait donc fonctionner sans problème normalement vu que ce n'est pas un NVMe mais un SATA justement;

Je vous tiens au courant ;)

ThiWeb

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 4453
Enregistré le : il y a 9 ans

Message par LaDidi21 » il y a 3 semaines

@ThiWeb :
De quel modèle parlais-tu ? SC308 ? Si oui, c'est ce que j'ai et c'est du SATA.

N'oublie pas : "NVMe" est un abus de langage. Il faudrait écrire : "NVMe over PCIe".
860 EVO SATA M.2, c'est ce que j'achète.

Bizarre, dans le BIOS "GL12CP-AS.309", on trouve un driver pour NVMe...
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9422
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 3 semaines

Dans le BIOS 309, tu trouves des pilotes NVMe car la plupart des modèles utilisant ce BIOS on un port M.2 NVMe.
Mais il a fallu que moi, je tombe sur la version SATA.

Ceci dit, le poste en question est le moins chère de la gamme, moins de 1000 € avec un i7.
Alors que le même produit dans une gamme différente, peut dépasser les 2000 €.

Voilà celui que j'ai acheté :
https://www.cdiscount.com/informatique/ ... r077t.html

ThiWeb

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 4453
Enregistré le : il y a 9 ans

Message par LaDidi21 » il y a 3 semaines

@ThiWeb :
Je n'avais pas regardé que ce BIOS était éligible pour d'autres UC...

Dans l'absolu, on est limite "tromperie sur la marchandise". Mais la faire valoir avec CDiscount, ce n'est pas une sinécure...
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9422
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 3 semaines

Ils sont malins, ils ne parlent ni de SATA ni de NVMe.
Ils parlent juste de SSD.

Partant de là, ça peut être tout et n'importe quoi...
Quoiqu'il en soit, je suis content que Samsung commercialise encore le 860 EVO qui lui, est en SATA et pas en NVMe.
Amazon livraison en 1J ouvré, je le reçois ce matin, tout devrait fonctionner normalement
Retour du NVMe et remboursement à 100 %.
Amazon PoWaA ! Y'a pas à dire, ils sont bons, et le client n'attend pas trop.

ThiWeb

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9422
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 3 semaines

Résolu
Ayant reçu le 860 EVO de Samsung, qui a la particularité d'être en SATA et non en NVMe, celui-ci a été reconnu direct et tout fonctionne parfaitement.
Le ports M.2 de cette machine est donc bien un SATA et pas un NVMe.
Tout roule.

Merci à tous,

ThiWeb

Avatar du membre
Joselito
Grand Habitué
Grand Habitué
Messages : 575
Enregistré le : il y a 5 ans

Message par Joselito » il y a 3 semaines

Du coup mis à part l'encombrement, l'intérêt de ce port M.2 est mineur, non ?
1 port SATA en plus.

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9422
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 3 semaines

Ouai, je suis bien d'accord.
Pour moi un M.2, ça DEVRAIT FORCÉMENT être NVMe.
Parce qu'un M.2 SATA n'a aucun intérêt en effet…

Dans le cas présent, y'avait un SSD M.2 que je voulais remplacer par plus grand et définir par défaut.
Raison pour laquelle je me suis concentré sur le M.2.

D'ailleurs dans le BIOS/UEFI, le SSD M.2 SATA apparait comme lecteur 0, ce qui est bien.
Ça fait de lui le périphérique de stockage prioritaire.

Alors que dans ma RoG Maximus VIII Ranger, le SSD M.2 NVMe apparait comme lecteur 5-6-7-8, dépendant du nombre de SATA connecté en plus.
Si aucun SATA n'est utilisé, alors le M.2 NVMe devient 0, si 1 SATA, 1, si 2 SATA, 2, etc.
En gros, le NVMe sera toujours le dernier lecteur listé par l'UEFI.

Étrange… Mais peut-être normal.
Quoiqu'il en soit, tout fonctionne parfaitement.

ThiWeb

PhilWEB
Nouveau
Nouveau
Messages : 47
Enregistré le : il y a 2 ans

Message par PhilWEB » il y a 3 semaines

Petite mésaventure !!!
Tu as retourné le disque M2 NVMe en échange du M2 SATA ?
A ce qu'il parait pour les ports M2, la différence en terme de vitesse n'est pas vraiment flagrante entre un transfert SATA III et le NMVe d'après ce que j'ai pu voir
La différence se situe surtout dans les copies de gros fichiers où la vitesse de transfert / sata I/II/III est multiplié par 4 voire 5.
Par contre aucune différence avec un transfert sur un disque dur mécanique interne ou externe car on est limité justement par le transfert du débit SATA III qui plafonne pour ma part à 120/150 Mo/sec
Pour la bureautique, on voit pas la différence.Pour lancer un jeu, le gain est minime (1 voire 2sec)
A ce propos, j'ai regardé la description de ta bécane et super !!!! tu as en promo Call Of DUty Black Ops IV.

Avatar du membre
Auteur du sujet
ThiWeb
Administrateur
Administrateur
Messages : 9422
Enregistré le : il y a 9 ans
Localisation : On earth
Contact :

Message par ThiWeb » il y a 3 semaines

Ouep, j'ai effectivement retourné le NVMe en échange du SATA.
La différence entre le M.2 SATA et le M.2 NVMe est effectivement minime, sauf sur des tests bruts de copie de fichiers.
Car SATA = 500 Mo / sec
NVMe = 2500 Mo / sec
Mais ça c'est la théorie et dans des conditions particulières.

A part ça, le PC est top en effet et CoD offert en effet ^^

ThiWeb ;)

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités