[RÉSOLU] Raccourcis vers pages Web après désinstallation d'Internet Explorer 11

Vous recherchez un programme, une solution, posez votre question ici.
Répondre
Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

[RÉSOLU] Raccourcis vers pages Web après désinstallation d'Internet Explorer 11

Message par Joselito »

Un petit blème agaçant dont je viens de m'apercevoir.
Lorsque je crée un raccourcis vers une page web et que je l'ouvre avec l'application par défaut (Edge Chromium), j'obtiens ceci :

Image

Si je fais Clic droit > Ouvrir avec > Navigateur Internet, la page s'ouvre correctement dans Edge.

Windows 10 Pro 2004
Seul navigateur Edge Chromium, ouvre par défaut .url, .htm, .html
J'ai supprimé récemment Internet Explorer
Avez-vous rencontré ce soucis ?

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 6874
Enregistré le : il y a 10 ans

Message par LaDidi21 »

@Joselito :
Le raccourci dont tu parles est un .url ?
Tu as un outil chez nirsoft pour voir ce qui s'ouvre : FileTypesMan v1.95
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@LaDidi21,
Voici l'exemple que j'ai mis en capture d'écran :

Image

Raccourcis fait à la souris en emmenant l'icone immédiatement à gauche du champ d'adresse du navigateur.
Mais idem si je fais un raccourcis avec Clic droit > Nouveau > Raccourcis et "https://www.google.fr/" comme emplacement.
A chaque fois effectivement le raccourcis prend une extension .url

Edit.
Je viens de regarder mon portable, il n'a pas ce problème et les raccourcis ne prennent pas d'extension .url.
Et je ne lui ai pas supprimé Internet Explorer 11.

Xeos
Habitué
Habitué
Messages : 157
Enregistré le : il y a 1 an

Message par Xeos »

@Joselito

Sur le Bureau Clique droit, Nouveau Raccourci tu colles l' url
et ça doit s'ouvrir avec le navigateur par défaut.

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@Xeos,
Qu'importe la façon de créer le raccourcis, il ouvre Edge mais affiche l'URL sous forme de texte, sans afficher la page.

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 6874
Enregistré le : il y a 10 ans

Message par LaDidi21 »

@Joselito :
A mon humble avis, Edge n'interprète pas les .url.
En tout cas, Edge 83.0.478.54 + W7 => les .URL sont présentés comme du texte.

Créer un raccourci d'URL qui ouvre dans Edge quel que soit le navigateur par défaut
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Xeos
Habitué
Habitué
Messages : 157
Enregistré le : il y a 1 an

Message par Xeos »

j'ai arrivé a reproduire ton problème sur 2 postes avec Edge Chromium version 83.0.478.56

- Windows 10 Pro 1909
- Windows 10 Famille 2004

Le raccourci fonctionne parfaitement sous Edge Chromium.

Maintenant le problème apparait suite au redémarrage du poste après avoir décoché dans Fonctionnalités Facultatives Internet Explorer 11 (désinstallation de IE 11).
Le fichier url n'est plus associé automatiquement à Edge Chromium, après si tu associe le fichier url du raccourci à Edge Chromium celui ci ne vas pas ouvrir l'url, mais plutôt le contenu du raccourci.

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@LaDidi21,
Un raccourcis vers "microsoft-edge:http://www.google.com" par exemple me donne toujours une page Web "C:/Users/nom_utilisateur/Desktop/Nouveau%20raccourci%20Internet.url" avec juste l'url en texte.

@Xeos,
Oui, je subodore effectivement que c'est lié à la désinstallation d'IE 11. En tout cas il y a une concordance de temps.

Demain je teste une réinstallation d'IE et/ou d'Edge.

Avatar du membre
ThiWeb
Administrateur
Administrateur
Messages : 8915
Enregistré le : il y a 10 ans
Localisation : On earth
Contact :

Message par ThiWeb »

Dire que ce putain d'IE inutile cause des problèmes sous Edge Chromium...
Je ne comprends pas pourquoi Microsoft ne décide pas d'annihiler ce truc de Windows 10.
Franchement en 2020 IE quoi... 🤔

ThiWeb

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 6874
Enregistré le : il y a 10 ans

Message par LaDidi21 »

@Joselito :
Tu as regardé ce que donnait FileTypesMan ?
Regarde si le protocole ms-edge est bien associé à Edge Chromium via URLProtocolView v1.15
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@LaDidi21,
Oui j'ai regardé mais il y a beaucoup d'info.
Ce qui est sûr c'est que les .html et .htm d'une part et .url d'autre part ne sont pas traitées de façon identique.
J'affine ce soir.

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@LaDidi21,
Pas de trace d'un protocole ms-edge dans aucun des 2 logiciels.

Image

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 6874
Enregistré le : il y a 10 ans

Message par LaDidi21 »

@Joselito :
Sous FileTypesMan, il faut regarder la ligne .URL, la colonne UserChoice.
Il faut regarder dans le panneau d'en bas les verbes (Open, print, ...) et la ligne de commande associée.

Bizarre que URLprotocolView ne présente pas ms-edge:
Le protocole n'apparait qu'ici. Il n'apparait pas sous FileTypesMan.
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@LaDidi21,

Cela n'affiche qu'une ligne dont voici la partie gauche :

Image


Edit :
Pour résumer le problème : au lieu de créer un raccourcis vers une page web, Windows crée un fichier texte .url qui contient l'adresse !
C'est clairement lié à la désinstallation d'IE11 (reproductible sur VM).
Et surtout, réparation obtenue en faisant : Clic droit > Ouvrir avec > Choisir une autre application > Navigateur Internet (celui avec l'icone de maison)
en cochant "Toujours utiliser cette application..."

Pour finir voici ce que renvoie FilesTypeMan maintenant :

Image

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 6874
Enregistré le : il y a 10 ans

Message par LaDidi21 »

@Joselito :
Les 2 DLLs ieframe et mshtml sont-elles toujours présentes APRÈS la désinstallation d'IE ?
  • Si non... c'est cuit
  • Si oui, il suffit juste de les ré-enregistrer (RegSvr32 ...)
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@LaDidi21,
Oui, elles sont toujours présentent.
Merci de ton aide, je passe en résolu.

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 6874
Enregistré le : il y a 10 ans

Message par LaDidi21 »

@Joselito :
Il serait intéressant de regarder la version de ces DLLs
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@LaDidi21,
- ieframe.dll 11.0.19041.329
- mshtml.dll 11.0.19041.329

Versions identiques à celles du portable sur lequel je n'ai pas touché à IE11.

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 6874
Enregistré le : il y a 10 ans

Message par LaDidi21 »

@Joselito :
11.0.... Tiens, tiens !
C'est donc des DLLs d'IE11.
D'où le bazar quand tu désinstalles IE11
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

Moralité : IE11 n'est pas aussi facultatif que Microsoft le prétend pour le moment.
:hushed:

Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 6874
Enregistré le : il y a 10 ans

Message par LaDidi21 »

@Joselito :
Tu en doutais ^^ ?
Tu fais confiance à M$ sans vérifier, toi :kiss: ?
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-

Avatar du membre
Auteur du sujet
Joselito
VIP
VIP
Messages : 1096
Enregistré le : il y a 6 ans

Message par Joselito »

@LaDidi,
Le moins possible.
Pourtant nous leur confions beaucoup de choses un peu malgré nous.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités