[RECHERCHE] Archicad 26 FR + Potion

Vous recherchez un programme, une solution, posez votre question ici.
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

[RECHERCHE] Archicad 26 FR + Potion

Message par Domal »

Bonjour,

Sujet partiellement abordé dans le fil de discussion de la version 25, je me permets d'ouvrir un sujet sur la version 26 d'Archicad.
En effet un lien de la version 26 en langue anglaise a été proposé par Barca.

Quelqu'un aurait-il une proposition pour la version française d'ARCHICAD 26 ? (version actuelle Build 3010 en x64)
La version de 30 jours est téléchargeable sur le site de l'éditeur (Abvent / Graphisoft), donc un patch seul de la version française serait apprécié.

Ne possédant pas de machine virtuelle, je n'ai pu tester le patch de la version EN avec la version FR. Mais d'après le message de PhilWEB, page 5 du fil de discussion de la V25, cela n'a pas l'air fonctionnel...
Je remercie donc par avance, la ou les personnes qui pourront trouver une solution de patch pour la version 26 FR d'Archicad. :thumbsup:

Merci pour votre contribution ! ;)
Avatar du membre
Joselito
Modérateur
Modérateur
Messages : 2460
Enregistré le : il y a 9 ans

Message par Joselito »

Domal a écrit : il y a 1 mois Ne possédant pas de machine virtuelle,
C'est un tort.
Domal a écrit : il y a 1 mois je n'ai pu tester le patch de la version EN avec la version FR.
Il me semble l'avoir fait, ça ne fonctionne pas.
Avatar du membre
nenyp
Grand Habitué
Grand Habitué
Messages : 561
Enregistré le : il y a 8 ans

Message par nenyp »

@ Domal

La première 3001

Archicad-26-FRA-3001-1.0 - 3 Go

Code : Tout sélectionner

TWL2.383D6C653F623461346770776F2D6F636E287F626F6470757F2F2A337074 74786
Non testé
Windows 11 21H2 222000.1042
Processeur Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
Mémoire RAM installée 16,0 Go
Système d’exploitation 64 bits
GeForce GTX 1070
Avatar du membre
nenyp
Grand Habitué
Grand Habitué
Messages : 561
Enregistré le : il y a 8 ans

Message par nenyp »

@ Domal

Sinon la 3010 ici :

Code : Tout sélectionner

Edit LaDidi21 (12/09/2022 : Session invalid.
Non testé

Essaie de voir si tu peux utiliser le patch sur la FR
Windows 11 21H2 222000.1042
Processeur Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
Mémoire RAM installée 16,0 Go
Système d’exploitation 64 bits
GeForce GTX 1070
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

Merci pour la rapidité de vos réponses.

@Joselito
Je ne peux qu'abonder dans ton sens...bien sur que c'est une lacune... :'(
Je reconnais que je n'ai jamais pris le temps de faire une install d'une VM et de voir comment maitriser l'ensemble...
J'espère le faire à un moment, mais malheureusement j'ai d'autres "urgences" avant de me mettre à tester cela.
De ton côté, sauf erreur, tu cherchais un logiciel d'architecture et tu devais tester Archicad...As-tu essayé ? Si oui as tu persévéré et comment l'as-tu trouvé ?

@nenyp
Merci pour tes propositions nenyp
Néanmoins, j'ai un retour de - session invalid - sur ton deuxième lien.
Avatar du membre
nenyp
Grand Habitué
Grand Habitué
Messages : 561
Enregistré le : il y a 8 ans

Message par nenyp »

@ Domal

Le lien fonctionne chez moi.

Et là ? :

Code : Tout sélectionner

Edit LaDidi21 (12/09/2022 : ERROR: File or folder not available!
Windows 11 21H2 222000.1042
Processeur Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz
Mémoire RAM installée 16,0 Go
Système d’exploitation 64 bits
GeForce GTX 1070
PhilWEB
Habitué
Habitué
Messages : 356
Enregistré le : il y a 6 ans
Localisation : Nouvelle Aquitaine

Message par PhilWEB »

Vous me direz ce qu'il en ressort de vos tests.
Je n'ai testé que la version française en récupérant le patch de la version anglaise que je n'ai pas installé.
Un bidouilleur calé français trouvera probablement la solution à partir du patch anglais ou d'une autre build du programme.
Avatar du membre
Joselito
Modérateur
Modérateur
Messages : 2460
Enregistré le : il y a 9 ans

Message par Joselito »

Si ma mémoire ne me trahit pas, la version d'essai 30 jours en français, réclame malgré tout un code dispensé par l'éditeur une seule fois par compte.
PhilWEB
Habitué
Habitué
Messages : 356
Enregistré le : il y a 6 ans
Localisation : Nouvelle Aquitaine

Message par PhilWEB »

@joselito
Oui
Donc ayant chargé une ancienne version pour laquelle nous avons obtenu un code via un compte créé chez l'éditeur, lorsqu'on recharge une autre version, il doit considérer dans la mesure où nous ne sommes pas clients, que nous sommes de potentiels utilisateurs frauduleux lorsque le programme se connecte à internet au moment de l'installation en recherchant dans notre base de registre windows.
Il doit savoir si le programme a déjà été installé sur le pc considéré
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@nenyp
Oui merci ton 2eme lien fonctionne. Merci !

Néanmoins cela reste un lien et non un ensemble testé, qui plus est en version EN d'après ce que j'ai compris et non en version FR.
Comme je l'ai indiqué, je n'ai pas de VM et ce n'est donc pas facile pour moi de partir dans l'aventure des tests...de ce fait si toutefois quelqu'un avait une potion déjà testée et éprouvée cela serait un + pour moi, et apparemment pour d'autres forumeurs...

Merci d'avance. ;)
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@ Joselito
Je n'avais pas cette information, et je ne peux donc pas te confirmer cela.
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

Devant le peu de réponses, hors celles de Joselito et de nenyp que je remercie au passage, j'ai suivi les conseils de Joselito en prenant le temps d'essayer d'installer une machine virtuelle sur mon PC.

J'ai donc installé une machine virtuelle, un OS, puis la version d'Archicad 26 proposé par nenyp dans son 3e message de ce fil de discussion.
Installation bien passée, mise à jour du soft, utilisation de la cerise, mais ensuite message d'erreur au lancement du soft :
Bug Reporter Graphisoft : Un problème s'est produit et l'application s'est terminée...

De ce fait pour vérifier si cela venait du soft ou de la machine virtuelle, j'ai téléchargé sur le site de Graphisoft une version d'évaluation, et je te confirme Joselito qu'il faut un serial pour lancer la version d'évaluation.
Serial expédié par mail suite à l'inscription et au téléchargement de la version d'éval.

Création d'une nouvelle machine virtuelle, et même bug avec la version d'évaluation du logiciel.

Image
Image
Code du fichier d'erreur
Image

:warning: Machine ayant servie aux tests
- Ordinateur fonctionnant sous windows 10 à jour, 16Go de Ram, Core i5
- Logiciel de virtualisation VMware workstation 16 pro V16.2.3 build 19376536
- OS installé sur la MV, Win 10 Pro 64 bits, 1 processeur 4 coeurs, 8GO de Ram, 200Go de disque, pas d'accès au réseau internet

Je sollicite donc les bonnes âmes qui voudront bien vouloir m'aider dans la recherche dudit bug, certainement issue de la machine virtuelle que je ne maitrise pas grandement...lol

Merci de m'avoir lu et merci d'avance pour votre aide. :thumbsup:
Je reste à votre disposition pour toute indication que j'aurai oublié de partager.
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 10109
Enregistré le : il y a 13 ans

Message par LaDidi21 »

@Domal :
Dans la mesure où tu as le même bug avec la version d'éval, envois le log à l'éditeur.
La copie d'écran du log d'erreur est illisible.
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@LaDidi21
Effectivement le code manquait de visibilité via l'image postée, mais je ne voulais pas faire un post trop long...je trouvais déjà que j'étais limite en taille. Je sais que beaucoup de personnes "zappe" lorsque c'est trop long.
Je me permets donc de te mettre le code, même si je n'ai pas trouvé une police pour rendre le tout plus lisible.
Pour ce qui est d'envoyer le fichier d'erreur a l'éditeur, le problème est que l'install est sur une machine virtuelle que je ne maitrise pas, et ils risquent de m'indiquer que le problème vient de ma plateforme et donc qu'ils n'apportent une assistance que sur leur produit et non pas sur la plateforme d'acceuil.

Si toutefois tu souhaitais avoir d'autres éléments ou un codage différent du fichier log, ne te prive pas de me le demander.

Merci d'avance si toutefois tu trouvais une piste pour m'aider. :thumbsup:

Code : Tout sélectionner

÷z¼cúþx      ÿ™  S:C,S:C Creating file "%" in folder "%"Ð IO  ÿ Log-166282764214248-1.logÿ% C:\Users\Phil\Graphisoft\GSReportLogsÿš  S:C,S:C,S:C( Opening file "%" in folder "%" in % modeÐ IO   ÿ write-only empty shared to readøWW,áÙƒˆàHŒO}W>šXz¼c   ÷z¼cúþx      ÿ›  Dt,T Logging started at % %Ð    z¼cz¼cÿ—  S:C,S:C! Creating folder "%" in folder "%"Ð IO  ÿ
 GSReport-4248ÿ  C:\Users\Phil\AppData\Local\Tempÿ™  S:C,S:C Creating file "%" in folder "%"Ð IO  ÿ GSReportUserAction.logÿ. C:\Users\Phil\AppData\Local\Temp\GSReport-4248ÿ–  S:C  MUI process preferred language %Ð    ÿ fr-FRÿ•  S:C MUI language fallback list %Ð    ÿ fr-FR | fr | en-US | en÷}¼cÿš  S:C,S:C,S:C( Opening file "%" in folder "%" in % modeÐ IO  ÿ ProductVersion.xmlÿ' C:\Program Files\Graphisoft\Archicad 26ÿ	 read-onlyÿœ  S:C,S:C Closing file "%" in folder "%"Ð IO  ÿ  S:C,S:C,S:CQ Connection to file "%" in folder "%" has failed: file is not found (OS errors: %)  IO  ÿ GSAutoTester.DLLÿ~ FindFirstFile: 2 = "Le fichier spécifié est introuvable. ", GetFileAttributes: 2 = "Le fichier spécifié est introuvable. "ÿ appendÿž  S:C  GSReport user action log line: %Ð    ÿ} SetRptLocations with input location: C:\Users\Phil\Graphisoft\BugReporting-26\Archicad-20220910(16-33-17)-[5016]-1-FATAL.RPT.ÿs RPT file location was set: C:\Users\Phil\Graphisoft\BugReporting-26\Archicad-20220910(16-33-17)-[5016]-1-FATAL.RPT.ÿt RPT file pair location is: C:\Users\Phil\Graphisoft\BugReporting-26\Archicad-20220910(16-33-17)-[5016]-1-FATAL.rpta.ÿt RPT file location was set: C:\Users\Phil\Graphisoft\BugReporting-26\Archicad-20220910(16-33-17)-[5016]-1-FATAL.rpta.ÿ="C:\Users\Phil\Graphisoft\BugReporting-26\Archicad-20220910(16-33-17)-[5016]-1-FATAL.RPT" "C:\Users\Phil\Graphisoft\Archicad Dossier journal\Archicad 26.0.0 FRA R1\UsageLogger\Log_ul-1662827600_1_5016.log" "C:\Users\Phil\Graphisoft\Archicad Dossier journal\Archicad 26.0.0 FRA R1\FastLogger\Log-166282760215016-1.log"ÿ' PID > 4248, Process name > GSReport.exeÿ# PPID > 5016, Process name > UnknownÿŸ  S:CR GSR::PreferencesPrivacyStore::LoadPrivacyPermissionTime -> returned with error: %s     ÿ -2130705150ÿ   S:CK GSR::PreferencesPrivacyStore::LoadContactAddress -> returned with error: %s     ÿ¡  S:C "%" modal dialog openedÐ Archicad Userÿ Bug Reporter÷µ¼cÿ¢  S:C,S:C "%" modal dialog closed with %Ð Archicad Userÿ OK	
ÿ Traitement du rapport de bogueÿ wow64cpu.dllÿ  ÿ wowarmhw.dllÿ
 xtajit.dllÿ advapi32.dllÿ clbcatq.dllÿ combase.dllÿ COMDLG32.dllÿ	 coml2.dllÿ difxapi.dllÿ	 gdi32.dllÿ gdiplus.dllÿ IMAGEHLP.dllÿ	 IMM32.dllÿ kernel32.dllÿ	 MSCTF.dllÿ
 MSVCRT.dllÿ NORMALIZ.dllÿ NSI.dllÿ	 ole32.dllÿ OLEAUT32.dllÿ	 PSAPI.DLLÿ
 rpcrt4.dllÿ sechost.dllÿ Setupapi.dllÿ
 SHCORE.dllÿ SHELL32.dllÿ SHLWAPI.dllÿ
 user32.dllÿ WLDAP32.dllÿ	 wow64.dllÿ wow64win.dllÿ
 WS2_32.dll÷¼¼cÿ/ Archicad-20220910(16-33-17)-[5016]-1-FATAL.rptaÿ( C:\Users\Phil\Graphisoft\BugReporting-2689ÿ ComputerInfo.XML:ÿ write-only empty:ÿ Traceur.prfÿB C:\Users\Phil\AppData\Roaming\Graphisoft\Archicad-64 26.0.0 FRA R1ÿ’ FindFirstFile: 3 = "Le chemin d’accès spécifié est introuvable. ", GetFileAttributes: 3 = "Le chemin d’accès spécifié est introuvable. "<ÿF C:\Users\Phil\AppData\Roaming\Graphisoft\Archicad-64 26.0.0 FRA R1\x86>ÿ GSReport-report.tmpÿ0 CrashDump-20220910(16-33-58.922)-[5016-1872].dmp9A9::ÿ Log_ul-1662827600_1_5016.logÿT C:\Users\Phil\Graphisoft\Archicad Dossier journal\Archicad 26.0.0 FRA R1\[email protected]@ÿ' DESKTOP-783BQC2-2022-09-10-18-35-08.repD;[email protected]ÿ ReportSubmitterSubmission.logEÿ
 write-onlyÿ  Soumission Graphisoft Bug ReportúþÜ      DDÿ  S:C,S:C,S:CT HttpProxyConfiguration: system proxy settings: server: %, proxies: %, bypass list: %Ð HTTP  ÿ http://gsreport.graphisoft.comÿ  S:C+ HttpProxyConfiguration: server: %, proxy: -Ð HTTP  Hÿ FileSubmitter_CURL.out
ÿ£  S:C,S:C  Deleting entry "%" in folder "%"Ð IO  ÿ+ DESKTOP-783BQC2-2022-09-10-18-35-08.rep.zipú Gÿ [email protected]ÿ. Archicad-20220910(16-33-17)-[5016]-1-FATAL.RPT989A9ÿ Retour rapport de bogue÷ð¼cÿ¤  S:C,S:C,S:CU Connection to folder "%" in folder "%" has failed: folder is not found (OS errors: %)  IO  ÿ Files÷½cN÷*½cN÷7½cN÷ñ½cM ÿ¥  Dt,T Logging stopped at % %Ð    ñ½cñ½c
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 10109
Enregistré le : il y a 13 ans

Message par LaDidi21 »

@Domal :
Pour la log, soit tu l'encadres par un tag CODE :

Code : Tout sélectionner

... mon log ...
soit tu uploades le fichier complet (ou partiel) sur un hébergeur et tu postes le lien.
J'ai édité ton post pour ajouter le tag.
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@LaDidi21
Merci d’avoir corrigé mon post. Effectivement je n’avais pas été attentif à cette mise en forme qui rend plus propre et plus lisible mon message.
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 10109
Enregistré le : il y a 13 ans

Message par LaDidi21 »

@Domal :
Poste le fichier de log car il contient des caractères exotiques...

Concernant le support, poste la question et tu verras bien leur réponse.
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@LaDidi21
Je vais suivre tes conseils et envoyer le fichier au support concerné et je verrai bien leur réponse.
Concernant ledit fichier log, je te le propose ci-dessous.
Merci pour ta contribution.

Lien 1fichier

Code : Tout sélectionner

TWL2.39657A75616165757572387B6F6270356F6337366F3F2D6F636E22756968 636966613F2F2A33707474786
Lien Uptobox

Code : Tout sélectionner

TWL2.346632777160796A68637D623F2D6F636E287F626F6470757F2F2A337074 74786
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 10109
Enregistré le : il y a 13 ans

Message par LaDidi21 »

@Domal :
La log n'est pas prévue pour être lue par un éditeur de texte standard. Il faut un outillage particulier.
J'ai l'impression que le problème viendrait de l'absence du fichier "GSAutoTester.DLL" ?

Tu peux essayer de faire tourner Process Monitor et voir si une anomalie évidente apparait ?
Si tu ne l'as jamais utilisé, teste d'abord sur NotePad pour le comprendre...
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@LaDidi21
J'ai installé Process monitor, mais ensuite être capable de l'exploiter c'est autre chose...
Je n'ai pas la compétence pour exploiter ou rechercher efficacement un problème, au regard de toutes les données fournies par le soft...
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 10109
Enregistré le : il y a 13 ans

Message par LaDidi21 »

@Domal :
Tu as sélectionné NotePad seul, déjà ?
Tu peux toujours déposer le fichier de log de "Process Monitor" si quelqu'un veut regarder...

Tu peux répondre au support que tu as ajouté l'accès à Internet et que l'installation génère toujours la même erreur ^^ .
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@LaDidi21
Merci de me mettre dans l'embarras... :p Je ne vois pas la sélection de Notepad seul... :joy:
Pour ce qui est du fichier, si quelqu'un est interessé qu'il le dise...car en .xml il fait 250Mo et en natif du soft en .pml il fait 700Mo. Tu vois que je n'ai pas activé Notepad seul. 8|

Pour la réponse du service technique, je les ai relancé mais pas de réponse aujourd'hui.
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 10109
Enregistré le : il y a 13 ans

Message par LaDidi21 »

@Domal :
Pour filtrer, tu peux utiliser la fonction "Filter" (6ème onglet) ou dans la colonne Processus, bouton droit sur le processus qui t’intéresse, Include '...'
Tu zippes le .pml (natif) et tu postes.

:warning: cf. ArchiCAD 26 - System Requirements, tu as vu qu'il faut un minimum de 16 Go de RAM et, non, 8 Go comme tu as ?
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@LaDidi21
En fait j'avais regardé pour la configuration minimale, et si effectivement 16Go sont recommandés, 8Go sont requis pour le faire tourner.
:warning: Mémoire requise minimale
De plus j'ai poussé jusque 12Go ce soir pour voir et cela ne change rien. Même un lien internet ne supprime pas le problème ! :@
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 10109
Enregistré le : il y a 13 ans

Message par LaDidi21 »

@Domal :
Pour ma part, je ne fais pas confiance à la traduction FR.
Ton test à 12 Go n'a pas d'intérêt si le minimum exigé est 16.
Pose la question à l'éditeur sur ces différences de prérequis pour avoir un statut clair.

:pensive: Process Monitor ne sera, ici, d'aucune utilité.

Je crashe, aussi, avec la version INT (et non FR) sur une VM avec 8 Go.
Je pense que le problème ne vient pas de la taille de la VM.

Lorsqu’il apparait la fenêtre "Bug Reporter", ne pas la fermer.
Va dans le répertoire %USERPROFILE%\Graphisoft\BugReporting-26.
Tu dois trouver 3 fichiers, au moins :

Code : Tout sélectionner

13/09/2022  10:01            67 335 Archicad-20220913(08-00-57)-[3812]-1-FATAL.RPT
13/09/2022  10:01            67 771 Archicad-20220913(08-00-57)-[3812]-1-FATAL.RPTA
13/09/2022  10:01         1 273 783 CrashDump-20220913(08-01-13.703)-[3812-3952].dmp
Les 2 premiers sont nommés Archicad-%DATE%(%HEURE%)-[%PID%]-%n%-FATAL.RPT* :
  • %DATE% et %HEURE%" étant la date et l'heure du crash.
  • %PID% entre [] correspond au ProcessID d'ArchiCAD qui a crashé... sûrement, ArchiCAD.exe 8|
  • %n% : sûrement un N° séquentiel ?
Le fichier CrashDump ne te sera pas d'un grand intérêt sauf si tu es un spécialiste du dump.
Je n'ai pas bien vu l'intérêt de 2 reports (.RPT & .RPTA) mais c'est un choix éditeur, donc...

Dans mon cas :

Code : Tout sélectionner

...
Process ID  : 3812
Thread  ID  : 3952 (main)
GL_RENDERER: VMware SVGA 3D
System CPU Type: x86-64
OS Version  : Windows WorkStation (10.0) 10.0.19044 (64-bit) 

Session start: 2022/09/13 08:00:57
System time: 2022/09/13 08:01:11

* CORE: Failed to create Direct3D device

Call stack:
0x00007FF8759CD6BC!GSRoot.dll + 54972 (BugRep_ReportError + 96 bytes)
0x00007FF876BF29F6!Graphix.dll + 600566 (Graphix::D3D11RenderingCore::Get + 1626 bytes)
0x00007FF876BF12D6!Graphix.dll + 594646 (Graphix::OpenGLRenderingCore::Get + 9782 bytes)
0x00007FF876BF2405!Graphix.dll + 599045 (Graphix::D3D11RenderingCore::Get + 105 bytes)
0x00007FF876BE2F8E!Graphix.dll + 536462 (GraphixInit + 146 bytes)
0x00007FF61195CE52!Archicad.exe + 25480786 (VBElem::StairGenerator::StairSchemeGenOptionsData::operator= + 11462950 bytes)
0x00007FF6122CFECF!Archicad.exe + 35389135 (VBElem::StairGenerator::StairSchemeGenOptionsData::operator= + 21371299 bytes)
0x00007FF875A2629A!GSRoot.dll + 418458 (GS::Main + 46 bytes)
0x00007FF61259E0FE!Archicad.exe + 38330622 (VBElem::StairGenerator::StairSchemeGenOptionsData::operator= + 24312786 bytes)
0x00007FF61259C966!Archicad.exe + 38324582 (VBElem::StairGenerator::StairSchemeGenOptionsData::operator= + 24306746 bytes)
0x00007FF8B5717034!KERNEL32.DLL + 94260 (BaseThreadInitThunk + 20 bytes)
0x00007FF8B6462651!ntdll.dll + 337489 (RtlUserThreadStart + 33 bytes)
...
L'erreur est : "* CORE: Failed to create Direct3D device"
DirectX 11 est-il supporté dans la VM ?
Dans mon cas, dxdiag ("DirectX Diagnostic Tool"), onglet "Affichage" indique "DDI Direct3D : 10.1" => pas de support de directX 11 !

VMware indique : "To get started with DX11, VMware Tools needs to be upgraded, and the Virtual Hardware Compatibility version must be set to v18."
cf. Virtual machine hardware versions (1003746) : Virtual Hardware Compatibility >= 18 => Workstation 16 et +
Je suis en version VMware Workstation 15.5.7.
:skull: C'est cuit pour moi !

:thumbsup: En complément, la version de "Virtual Hardware Compatibility" est présent dans le fichier .vmx (fichier texte) de ta VM sous "virtualHW.version = "

Dans ton cas, il existe une version WorkStation 16.2.4-20089737. A tester ?
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
PhilWEB
Habitué
Habitué
Messages : 356
Enregistré le : il y a 6 ans
Localisation : Nouvelle Aquitaine

Message par PhilWEB »

Bonjour,

Effectivement,le problème doit venir de la version de DirectX utilisé par le soft.
Mon ati radeon 4800 de mon vieux PC ne supporte que la version 10.1 de directx alors que l'exigence minimale impose une version directx 11.
Je mettrai une ancienne version sur le vieux PC et j'essaierai la v26 sur l'autrre PC supportant le dirctx11 à temps perdu et quand il fera moins chaud
Auteur du sujet
Domal
Petit Nouveau
Petit Nouveau
Messages : 36
Enregistré le : il y a 1 an

Message par Domal »

@LaDidi21
Pour commencer, je voudrais te remercier pour ta contribution et surtout pour la qualité de celle-ci. La précision de tes réponses et la pertinence de celles-ci sont rares sur les forums aujourd'hui. Moi-même plutôt rigoureux, voire trop aux yeux de mon entourage, j'apprécie à juste titre ta méthode. Certains te "craignent", moi je valide ! J'ai moi-même par le passé apporté mon aide dans d'autres domaines à des personnes qui en avaient le besoin, et à ce titre je peux mesurer le travail et le temps, même pour un passionné, que cela représente. J'apprécie donc aujourd'hui à sa juste valeur d'être aidé dans un domaine que je ne maîtrise pas. Donc merci ! ;)

Pour le reste :
- Je suis d'accord avec toi que les 12 Go de RAM n'étaient pas utiles si le besoin est de 16 Go. Je voulais simplement m'affranchir que la limite des 8 Go était bien dépassée et que le soft ne bloquait pas par exemple en voyant 7.9 Go
- Toujours d'accord avec toi sur les traductions de documents en français. J'ai souvent été confronté au problème de documents traduits ou le traducteur "mettait sa patte personnelle" et modifiait le document d'origine.
- Je ne vais pas dire que je suis content que tu crashes aussi, avec la version INT, mais presque... xD

:warning: J'ai suivi tes conseils et j'ai regardé les fichiers dans le dossier BugReporting-26

N'étant pas un spécialiste de Dump, donc je n'aborde pas cette partie.

Pour moi après vérification, l'outil de diagnostic de Direct X m'indique Pilotes DDI Direct3D : 11
Donc oui DirectX 11 est supporté dans la VM que j'utilise

Mais le fichier Fatal.RPT n'est pas neutre puisqu'il m'indique -- ACCESS_VIOLATION reading location -- avec une indication de Graphix.dll
Qu'en penses-tu ? Le problème pourrait-il correspondre à cette référence ?

Voici une partie du code intéressant. Si tout souhaite l'ensemble du fichier, indique-le-moi mais à mes yeux le reste ne porte pas d'intérêt.
Note : J'ai juste remplacé dans le code le numéro de licence par des x

Code : Tout sélectionner

//================= BEGIN REPORT ======================

Exception (process terminated)
Computer-name: DESKTOP-783BQC2
User-name    : Phil
Account name : Phil
Domain name  : DESKTOP-783BQC2

Program Version: 26.0.0 R1 (3001) (64-bit)
Package Version: v2022 FULL FRA 3001
Program CPU Type: x86-64
Command Line: <"C:\Program Files\Graphisoft\Archicad 26\Archicad.exe" -starter=6716 -ipcdirect=tcp://127.0.0.1:65050>
Process ID  : 7640
Thread  ID  : 4488 (main)
GL_RENDERER: VMware SVGA 3D
LicenseData: TrialMode (xxxxxxxxxxxxxxxxxxxx)
LicenseDataEDS: TrialMode ()
ProjectFileName-ProjectOpeningProcess: Archicad.tpd
ProjectName: Sans titre
System CPU Type: x86-64
OS Version  : Windows WorkStation (10.0) 10.0.19044 (64-bit) 

Session start: 2022/09/13 12:29:18
System time: 2022/09/13 12:30:18

MS VC minidump file created at: CrashDump-20220913(12-30-18.380)-[7640-4488].dmp

Exception code: C0000005 ACCESS_VIOLATION reading location: 0000000000000000
Fault address:  00007FF81E355121 01:00034121 Graphix.dll
TOS   address:  0000013866FF6040 00:00000000 

Registers:
RAX:000001385E03E738
RBX:0000013866FF6040
RCX:0000000000000000
RDX:0000000000000006
RSI:0000000000000000
RDI:000001385DB6FD10
R8: 0000000000020000
R9: 0000000000020000
R10:0000000000000000
R11:0000000000000246
R12:0000000000000000
R13:0000013861927CD0
R14:0000000000000000
R15:00007FF65409BCFF
CS:RIP:0033:00007FF81E355121
SS:RSP:002B:0000000D8EEFE510  RBP:0000000D8EEFE620
DS:002B  ES:002B  FS:0053  GS:002B
Flags:00010206

Floating point Registers:
CTRL:027F  STAT:0000  TAGS:0000
CS:RIP:0000:0000000000000000
DS:EDO:0000:0000000000000000
MxCsr:00001FA0
Effectivement j'avais vu qu'il y avait une mise à jour disponible de VMware en 16.2.4 alors que je suis en 16.2.3 mais j'ai imaginé peut-être à tort que cela ne constituait pas un problème à ce stade d'investigation.

Je pense, sauf erreur, avoir répondu à l'ensemble de tes demandes. Je suis à ton écoute pour la suite des recherches...en lien avec Graphic.dll ?
J'ai lu quelques éléments sur internet à propos de ce fichier, mais je préfère avoir ton avis sur le sujet. :p
Avatar du membre
LaDidi21
Modérateur
Modérateur
Messages : 10109
Enregistré le : il y a 13 ans

Message par LaDidi21 »

@Domal :
:thumbsup: Les compliments sont rares donc je les prends bien volontiers.
On est dans un milieu technique, si on n'est pas pas "carré", on va dans les choux.
Après, il est vrai que j'ai mon caractère... mais beaucoup oublient qu'on travaille et on aide gracieusement, en plus de notre boulot.

Tu as, donc déjà, le support de directX 11 dans la VM: parfait.
A tout hasard, mets à jour en 16.2.4 et les tools en 12.1.0, celaa ne mange pas de pain 8|
Cela permettra, peut-être, de voir une erreur différente.

J'ai un doute : tu es sur la version Fr et non INT ?

L'erreur montre un pointeur nul => soit le développeur s'est planté soit le système lui renvoie une valeur inattendue...
Bizarre, je ne vois pas la "Call stack" dans ton exemple ? Oubli ?
C'est "Graphix.dll" et non "Graphic.dll" :tounge_xd:

Ce pourrait être intéressant de tester avec la version INT pour vérifier que l'erreur est identique ?
-> Décryptage des liens du forum : -/ extension "ThiWeb Crypt / Decrypt"™ ou -/ Thiweb Live <-
Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité