[MIGRATION] État du forum (+ changelog)

Parler de tout et de rien !
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

[MIGRATION] État du forum (+ changelog)

Message par Mimisiku »

Helloo!

Comme vous avez peut être remarqué / suivi, nous sommes passés sur un nouveau serveur, géré par nos soins, en Ukraine (toujours!) 🇺🇦.

En cas de soucis de connexion, videz les cookies ! ;)

(Message : "Le formulaire envoyé n’est pas valide. Essayez à nouveau." ou "Formulaire invalide")

Au menu :

- Changement des DNS RxName pour Cloudflare.
- Migration totale du forum sur un serveur chez Hostiko.
- Un nouveau mini-site permettant de surveiller nos services (accessible en haut du site) (hébergé en Finlande sur Hetzner).
- Correction des icônes Font-awesome sur le haut du site (passage en font-awesome dernière version planifié).
- Boost de performance sur l'ensemble du forum (minification, réduction des feuilles de style, des images, et passage sur notre propre style PhpBB (hérité de Prosilver).
- Ajout et correction de l'extension 2FA (retrait de U2F, design, mise à jour du javascript, implémentation de Webauthn possible (clé Yubikey) si demande des utilisateurs.
- Ajout d'un lien permettant de télécharger l'extension Chrome dans "l'Accès rapide" du site.
- Mise à jour vers la dernière version de jQuery, début de passage en Javascript natif pour l'ensemble de notre style.
- Des sessions plus longues ! Vous ne devrez quasiment plus vous reconnecter, si tout va bien. ;)
- Remplacement de Google Analytics par Abla Analytics conforme RGPD.
- Passage des e-mails via SMTP personnalisé Thiweb (AWS SES)

En test :

- Passage sur Kubernetes (Distro k3s)

A venir :

- Revue des politiques de sauvegardes (pour l'instant en daily via script) => Velero



N'hésitez pas à répondre à ce fil pour me prévenir de tout problème. (Ou idée)

+

Mimisiku.
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

Technologies utilisées sur le site :

Pour les versions de PhpBB / PHP, MariaDB, on suit ce que préconise "Bitnami" via leur helm chart PhpBB.

- Kubernetes (k3s)
- Debian 11 (Bullseye)
- MariaDB
- PHP 8.0 (avec les extensions dont PhpBB a besoin.)
- Wireguard (pour communiquer entre serveurs ou avec eux.)
- PhpBB (dernière version)

- UptimeKuma (Monitoring)
- Restic (Backup)
- Letsencrypt (SSL)

Performance :

Optimisation en cours, j'essaie de conserver PhpBB aussi "stock" que possible pour simplifier les mises à jour) :

- Lighthouse (Desktop + Mobile)
- Web.dev > Measure
- PageSpeed insights
- Dareboost
- GTMetrix

Techniques :

- Critical path CSS
- Minification + concaténation des feuilles de styles
- GZip + bonne politique de cache

Sécurité :

- Qualys SSL Test

Perso :

FAI : Orange (Livebox 6)
Machine : Mac Studio (macOS Monterey)
Clavier : Logitech MX Keys Plus
Souris : Apple Magic Trackpad
Gestion de projet : Tableau blanc ^^
Navigateur utilisé : Thorium (Version 107.0.5253.0 (arm64))
Éditeur de code : VSCodium
IDE Kubernetes : OpenLens
OTP : Yubico Authenticator + Yubikey 5C NFC
Avatar du membre
Sharko
Habitué
Habitué
Messages : 314
Enregistré le : il y a 13 ans
Localisation : Au milieu de l'eau

Message par Sharko »

Bravo Mimisiku, bravo à tous.

Sharko ;)
« Écouter est une politesse qu'un homme d'esprit fait souvent à un sot mais que celui-ci ne rend jamais »
Avatar du membre
Philoudemer
VIP
VIP
Messages : 1075
Enregistré le : il y a 9 ans
Localisation : Annecy
Contact :

Message par Philoudemer »

@Mimisiku
Combien d'heures pour ce Superbe travail ?
Bravo :thumbsup: et Merci. ^^
Avatar du membre
Mika
Nouveau
Nouveau
Messages : 47
Enregistré le : il y a 13 ans

Message par Mika »

Bonjour et Bravo Mimisiku
Superbe travail ;)
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

Philoudemer a écrit : il y a 2 semaines Combien d'heures pour ce Superbe travail ?
Je dirais entre 3 et 6 nuits :sweat_smile:
Avatar du membre
rembzh
Habitué
Habitué
Messages : 344
Enregistré le : il y a 4 ans
Localisation : Entre Alpes et Bretagne

Message par rembzh »

Merci Mimisiku et à tous les autres qui œuvrent dans l'administration de ce forum :thumbsup: :thumbsup: :thumbsup:
Bravo à tous.
La France est un petit pays coincé entre la Bretagne et la Belgique
Avatar du membre
nonodu12
Habitué
Habitué
Messages : 297
Enregistré le : il y a 9 ans

Message par nonodu12 »

Merci à toi Mimisiku
Bill_Boquet
Habitué
Habitué
Messages : 490
Enregistré le : il y a 8 ans

Message par Bill_Boquet »

Chapeau @Mimisiku pour cette migration en douceur et profondeur (dixit Adamo 8|). Et très impressionné par tous les logiciels avec lesquels tu jongles :thumbsup:.
Avatar du membre
Otite
Nouveau
Nouveau
Messages : 62
Enregistré le : il y a 8 ans

Message par Otite »

super boulot !!!!
Moi je dis toujours merci ! Donc MERCI !
regdit
Petit Nouveau
Petit Nouveau
Messages : 34
Enregistré le : il y a 10 ans

Message par regdit »

Merci pour tout se travail et pour cette migration ! :smiley:
Tartapuce
Nouveau
Nouveau
Messages : 75
Enregistré le : il y a 13 ans

Message par Tartapuce »

Bravo à tous !!!

Au top
:thumbsup: :thumbsup: :thumbsup:
Avatar du membre
DJoe
VIP
VIP
Messages : 1064
Enregistré le : il y a 13 ans
Localisation : Au chaud à l'abri de la pluie

Message par DJoe »

Grand merci à vous au top comme d'habitude :thumbsup: :thumbsup:
Avatar du membre
Calimero
Grand Habitué
Grand Habitué
Messages : 568
Enregistré le : il y a 9 ans
Localisation : Chti 59

Message par Calimero »

Bonjour,
@Mimisiku :
Super travail et rapide.
Souci : lors d’une connexion, dans le champ « mot de passe « , il n’y a pas l’œil pour afficher en clair le mot de passe, dans les navigateurs Firefox et IOS.
Est-ce possible de remédier à ce souci?
Avatar du membre
Barca
Grand Habitué
Grand Habitué
Messages : 1035
Enregistré le : il y a 2 ans
Localisation : CH

Message par Barca »

@Mimisiku
Bravo pour le travail.
Petit inconvénient, il y a une déconnexion automatique.
Le forum est ouvert dès que je suis sur un pc mais lorsque je reviens sur le forum après un temps variable, j'ai la vision du forum avec une alerte comme quoi je n'ai pas les droits et je dois me re-loguer.
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

Barca a écrit : il y a 1 semaine Petit inconvénient, il y a une déconnexion automatique.
Le forum est ouvert dès que je suis sur un pc mais lorsque je reviens sur le forum après un temps variable, j'ai la vision du forum avec une alerte comme quoi je n'ai pas les droits et je dois me re-loguer.
Tu peux essayer de cocher la case "Se souvenir de moi", voir si ça résout le soucis ?

J'ai encore quelques petits soucis à régler côté infra, et je passe à cette histoire de session ;)

@Calimero : Bonne idée l'affichage du mot de passe sur le login! Je vois pour faire ça quand j'ai un peu de temps
Avatar du membre
Barca
Grand Habitué
Grand Habitué
Messages : 1035
Enregistré le : il y a 2 ans
Localisation : CH

Message par Barca »

@mimisiku
Cela résout le soucis
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

@all : Problème de session corrigés (je coche par défaut la case "Se souvenir" au moins on est tranquilles.)

@Calimero : Petit oeil ajouté à côté du champ mot de passe lors de la connexion. ;)
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

@All : Mails réparés !

Image
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

En cas de soucis style "Formulaire invalide", videz vos cookies concernant ThiWeb.

Tuto : https://lecrabeinfo.net/google-chrome-s ... ns-du-site

+
Avatar du membre
Calimero
Grand Habitué
Grand Habitué
Messages : 568
Enregistré le : il y a 9 ans
Localisation : Chti 59

Message par Calimero »

Bonsoir,

@Mimisiku : merci d’avoir ajouté le petit œil pour le mot de passe.
Avatar du membre
nonodu12
Habitué
Habitué
Messages : 297
Enregistré le : il y a 9 ans

Message par nonodu12 »

Mimisiku a écrit : il y a 1 semaine En cas de soucis style "Formulaire invalide", videz vos cookies concernant ThiWeb.

Tuto : https://lecrabeinfo.net/google-chrome-s ... ns-du-site

+
Effectivement, ça vient de me le faire. Après vidage des cookies Ok. Pour autant mon pseudo était affiché en bas de la page en tant que membre actuellement connecté.
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

nonodu12 a écrit : il y a 1 semaine Pour autant mon pseudo était affiché en bas de la page en tant que membre actuellement connecté.
C'est normal, les pseudos restent affichés ~5min en bas du site.

Ça ne devrait plus le refaire concernant les cookies ;)

+
Avatar du membre
Barca
Grand Habitué
Grand Habitué
Messages : 1035
Enregistré le : il y a 2 ans
Localisation : CH

Message par Barca »

Mimisiku a écrit : il y a 1 semaine En cas de soucis style "Formulaire invalide", videz vos cookies concernant ThiWeb.

Tuto : https://lecrabeinfo.net/google-chrome-s ... ns-du-site

+
Problème rencontré sur le smartphone pas sur le PC.
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

Barca a écrit : il y a 1 semaine Problème rencontré sur le smartphone pas sur le PC.
Tu devais avoir un cookie non expiré invalidé résiduel, smartphone, PC ou tablette, c'est pareil ^^

Symptôme: "Formulaire invalide"
Correctif : Vider les cookies pour thiweb.com => vous reconnecter

J'ai mis à jour le post original avec les derniers changements + les technologies utilisées qui ont un peu changé (pour l'instant en test réservé au staff)
chico33
Petit Nouveau
Petit Nouveau
Messages : 18
Enregistré le : il y a 3 ans

Message par chico33 »

Bonjour,
Sous Edge, problème de connexion avec message "Le formulaire envoyé n’est pas valide. Essayez à nouveau."
Par contre, identification sans problème sous Chrome, Firefox et/ou Brave après suppression des cookies.
Bonne journée
Avatar du membre
Auteur du sujet
Mimisiku
Administrateur
Administrateur
Messages : 218
Enregistré le : il y a 13 ans
Localisation : Localhost
Contact :

Message par Mimisiku »

chico33 a écrit : il y a 1 semaine Sous Edge, problème de connexion avec message "Le formulaire envoyé n’est pas valide. Essayez à nouveau."
Par contre, identification sans problème sous Chrome, Firefox et/ou Brave après suppression des cookies.
Vide tes cookies sur Edge et ça devrait rouler ;)
chico33
Petit Nouveau
Petit Nouveau
Messages : 18
Enregistré le : il y a 3 ans

Message par chico33 »

Ben non et c'est pour cela que j'ai précisé l'avoir fait (suppression des cookies) avec succès pour les autres navigateurs mais ce n'est pas grave puisque je sais contourner le problème.
Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité